博客> cocoaPods2016 最新安装教程
cocoaPods2016 最新安装教程
2017-07-23 03:06 评论:0 阅读:256 守候的流年
ios 第三方库 cocoapods

cocoaPods2016
1、安装 Mac上面本来就自带了ruby,所以就不用自己安装了(除非你卸载了)。 打开Terminal(终端),输入以下命令(第二个命令可能会需要稍等一会儿)

gem sources --remove https://rubygems.org/ gem source -a https://gems.ruby-china.org

注:①第一个命令是移除官方源,因为在不翻墙的情况下,使用起来比较慢; ②第二个命令是添加ruby-china的RubyGems镜像(很多旧教程都是说使用taobao的gem源,但是taobao的gem源已经停止维护了,所以建议使用ruby-china, 接下来运行一个命令查看是否成功添加了ruby-china的gem源: gem source

出现下面情况说明配置完成:

CURRENT SOURCES

https://gems.ruby-china.org

注:如果是显示有其他的。请用第一个命令删除其他的ruby源,确保配置的正确性。

2、然后就可以开始真正安装CocoaPods了,输入一下命令:

sudo gem install -n /usr/local/bin cocoapods

等一会儿就能安装完成~~~

安装结束后,需要运行一下命令初始化CocoaPods: pod setup

没有什么错误的话,就算了安装结束了。(一般情况下pod setup 之后会在这里下载很多文件,大概100多兆的文件,静静地等待最终结果就可以了)

3、基本使用

打开Terminal(终端),cd到你的Project目录,输入一下命令: pod init 运行结束后,该目录下,会生成了一个Podfile文件 使用文本编辑器(vim、Sublime Text2、等等…)打开它(Podfile),大概会看到以下的东西

platform :ios, 'xxx' # 目标平台及其版本use_frameworks! # swift项目需要这句话,是Objective-C项目的话,请在前面加个#注释掉target 'xxxx' do

在这里添加你的依赖库说明,如pod xxx pod 'AFNetworking', '~> 3.1’ # 例如这是引入AFNetworking这个第三方库 (也可以直接输入pod 'AFNetworking' 代表是默认安装最新的版本) end

编辑完Podfile后,使用Terminal(终端)输入其中一个命令(需要cd到项目的根目录,即Podfile所在目录): pod install --no-repo-updateorpod install 第一个命令是不更新本地库信息进行安装,速度会快一点,毕竟不需要更新。但是会有一点点问题,当有一个新的库发布的时候,就会无法安装成功。如果不嫌麻烦,可以定时执行以下命令更新CocoaPods的库,然后就可以在一段时间使用以上的第一个命令进行安装: pod repo update 安装完成之后,打开项目就需要打开xxx.xcworkspace,而不是xxx.xcodeproj了 如果在安装之后,修改了Podfile文件,可以执行以下的其中一个命令进行库的更新(两个命令的区别和上面说的一样): pod update --no-repo-updateorpod update

安装CocoaPods的可能失败原因 gem过旧,使用以下命令更新一下,再进行安装(先切换到了ruby-china的gem源再运行一下命令更新): sudo gem update

附: 第一次使用安装框架 $ pod install 更新 $ pod update 搜索框架 $ pod search XXX 在项目文件夹下创建默认的 Podfile $ pod init Ruby 常用命令 添加源 $ sudo gem sources -a http://ruby.taobao.org/ 删除源 $ sudo gem sources -r https://rubygems.org/ 安装 $ sudo gem install cocoapods 设置 $ pod setup 查看gem源 $ gem sources –l gem自身升级 $ sudo gem update --system 查看版本 $ gem --version 清除过期的gem $ sudo gem cleanup 删除Cocoapods $ gem uninstall cocoapods 更新包 $ sudo gem update 列出本地安装的包 $ gem list

gem安装和更新: sudo gem install -n /usr/local/bin cocoa pods

注:本文是综合了本人多次错误的经验的出来的结果,不喜勿喷~~~~

收藏
2
sina weixin mail 回到顶部