博客> iOS-安装CocoaPods
iOS-安装CocoaPods
2017-10-17 07:28 评论:0 阅读:297 OS_JJ
ios 安装cocoapods

一. iOS 最新版 CocoaPods 的安装流程

    1.安装RVM

    (1)安装RVM                         curl -L get.rvm.io | bash -s stable
    (2)测试是否安装正常           rvm -v

    2.用RVM升级Ruby

    (1)查看当前ruby版本               ruby -v    
    (2)列出已知的ruby版本            rvm list known  
    (3)安装ruby 2.2.4(本人安装这个版本)   rvm install 2.2.4

    3.更换Ruby镜像

    (1)检查当前镜像                  gem sources -l  
    (2)移除当前镜像                  gem sources --remove https://rubygems.org/ (具体看你上一步检查的结果)
    (3)更换新的镜像                  gem sources -a https://gems.ruby-china.org/ 
                                               注:请检查是否安装过homebrew,未安装可能会导致opensll缺失,从而新源无法安装
    (4)检查新镜像是否安装成功     gem sources -l

    4.安装CocoaPods

    (1)旧版系统指令:                     sudo gem install cocoapods
       OS X EL Capitan升级后:      sudo gem install -n /usr/local/bin cocoapods
    (2)下载标准配置文件               pod setup
    (3)检查下载进度,新开一个终端窗口,输入 cd ~/.cocoapods/ 命令,执行 du -sh * 查看文件夹大小
    a.如果下载过程文件夹大小始终不变,则有可能需要删除master分支 sudo rm -fr ~/.cocoapods/repos/master 
    b.如果pod setup过程中,使用普通网络下载速度慢,下载中途出错,建议使用联通4G开热点给mac电脑
    c.共353M,使用4G热点约两分钟可以下载完,安装需要2-3分钟,安装完成后900多M
    (4)安装成功后,会有绿色提示,检查是否搜索到第三方库  pod search AFNetworking
    (5)编写工程的Podfile         cd 工程目录 vim Podfile
    (6)新版Podfile编写格式

    platform :ios, '8.0'
    use_frameworks!
    target '工程名' do
    pod "AFNetworking","3.0.4"
    end

二.如何升级ruby

    http://blog.csdn.net/lissdy/article/details/9191351

    1、安装 RVM
    RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)
        指令: curl -L get.rvm.io | bash -s stable 
    等待一段时间后就可以成功安装好 RVM。            
        source ~/.bashrc  
        source ~/.bash_profile  

    测试是否安装正常
        指令: rvm -v

    2、用RVM升级Ruby
        #查看当前ruby版本  
             ruby -v  
                ruby 1.8.7  
        #列出已知的ruby版本  
              rvm list known  
        #安装ruby 2.3.0  
               rvm install 2.3.0  
收藏
0
sina weixin mail 回到顶部