博客> Cocoapods的安装与使用
Cocoapods的安装与使用
2017-11-21 02:00 评论:0 阅读:103 青春追逐
版本更新

本帖最后由 优山美水iOS 于 2016-8-19 09:29 编辑

1.首先查看ruby版本 $ ruby -v 2.更新ruby源 $sudo gem update --system 3.如果用的还是taobao.org,需要移除更换成https://ruby.taobao.org/ $gem sources --remove https://ruby.taobao.org/ $gem sources -a https://gems.ruby-china.org $gem sources -l (查看当前ruby源) 4.安装cocoapods $sudo gem install cocoapods 5.关键一步 $git clone https://git.coding.net/Cocoapods/Specs.git ~/.cocoapods/repos/master 下载接近300M的文件 等下载好了在进行下一步的操作 6.设置pods $pod setup 耐心等待 执行完毕就可以使用了 7.$pod search 第三方库 这是优胜美地系统版安装方法 开普敦系统方法以后更新

8.使用 platform :ios, '8.0'

use_frameworks!个别需要用到它,比如reactiveCocoatarget 'MyApp' do pod 'AFNetworking', '~> 2.6' pod 'ORStackView', '~> 3.0' pod 'SwiftyJSON', '~> 2.3'end

收藏
0
sina weixin mail 回到顶部