博客> IOS 针对xcode 8 的cocoapods 最新安装教程
IOS 针对xcode 8 的cocoapods 最新安装教程
2017-11-22 02:22 评论:0 阅读:348 当空金色的阳光
ios cocoapods Xcode8
 自从xcode升级到8以后,发现安装cocoapods总是不成功或者用不了,我用下面的方法安装成功,有需要的人可以借鉴一下。

1.我们要安装RVM

 $ gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3
(上面这句我没用)
 $ \curl -sSL https://get.rvm.io | bash -s stable
 $ source ~/.bashrc
 $ source ~/.bash_profile
 $ echo "ruby_url=https://cache.ruby-china.org/pub/ruby" > ~/.rvm/user/db(修改安装源)

2.我们要安装Ruby

 列出已知的 Ruby 版本 -- rvm list known

 安装一个 Ruby 版本 --   rvm install 2.3.0 --disable-binary

 这里安装了最新的 2.3.0, rvm list known 列表里面的都可以拿来安装。

 切换 Ruby 版本 -- rvm use 2.3.0

 如果想设置为默认版本 -- rvm use 2.3.0 --default 

 查询已经安装的ruby --  rvm list

 卸载一个已安装版本 --  rvm remove x.x.x

3.这个时候我们要安装cocoapodes

  先查看自己使用的镜像源:gem sources -l
  我用的是https://gems.ruby-china.org/,淘宝的不能用了,请及时更换。
  更换命令:
                  gem sources --remove https://rubygems.org/ --之前的镜像
                  gem sources -a https://gems.ruby-china.org/ 
  安装并更新cocoapodes:
                  安装:sudo gem install cocoapods(不再使用)   
                  最新: sudo gem install -n /usr/local/bin  cocoapods(推荐)
                  更新:sudo gem update cocoapods 
  执行pod setup  会出现“Setting up CocoaPods master repo“提示,并一直处在这个状态。此时新开一个窗口输入"cd ~/.cocoapods/"命令行跳到cocoapods文件夹内,执行"du -sh *"命令看看文件大小是否是0,过一段时间再次执行该命令,如果文件在不断变大等待完成就可以使用了。

 以上是我的个人经历,如有问题欢迎指正和咨询。
收藏
0
sina weixin mail 回到顶部