博客> Mac10.12创建工程使用CocoaPods,未能生成*.xcworkspace 文件解决方法
Mac10.12创建工程使用CocoaPods,未能生成*.xcworkspace 文件解决方法
2019-10-18 09:13 评论:0 阅读:522 742724282

解决方案,如下: 1.先移除本地的CocoaPods版本, sudo gem uninstall cocoapods 2.然后再安装一个最新的版本 sudo gem install -n /usr/local/bin cocoapods --pre

然后,运行就可以了。

原因是:以前安装的版本是基于Mac 10.10到10.11之间的版本,直接升级ruby环境是没有用的,直接升级cocoaPods也是一样没有什么卵用,最佳的解决方案就是一移除,然后安装,就OK。

推荐两个越狱执行,Pod install:--》pod install --verbose --no-repo-update Pod update -- 》pod update --verbose --no-repo-update

收藏
0
sina weixin mail 回到顶部