博客> CocoaPods 配置工程三方库
CocoaPods 配置工程三方库
2017-10-17 16:43 评论:0 阅读:275 lsb
ios cocoapods

最近在github上下载了几个demo研究,发现安装后没法运行,网络上很多帖子说的不太具体(可能我理解不到位),最后自己参考着摸索解决后,写下来给大家分享下

1.http://www.jianshu.com/p/096a68d765a0 安装问题 2.http://blog.devtang.com/2014/05/25/use-cocoapod-to-manage-ios-lib-dependency/ 使用

从github上下载工程出现库调用问题解决 1.输入命令行切换到工程目录 cd "your project home" 2.指令安装需要的库 pod install 3.特别注意install可能会花一段时间(如果网络不好),要等待执行完成,不然没法创建xcworkspace文件
Pod installation complete! There are 3 dependencies from the Podfile and 3 total pods installed.

潜在问题,下载的工程Profile格式可能有问题导致报错
The dependency xxxxx is not used in any concrete target. 解决:按照如下格式处理后,再次执行pod install
platform :ios, '8.0'

use_frameworks!个别需要用到它,比如reactiveCocoa

target 'MyApp' do pod 'AFNetworking', '~> 2.6' pod 'ORStackView', '~> 3.0' pod 'SwiftyJSON', '~> 2.3' end

收藏
0
sina weixin mail 回到顶部