博客> cocoa pods的安装/更新以及一些常见问题
cocoa pods的安装/更新以及一些常见问题
2017-10-19 21:25 评论:0 阅读:274 星星点天灯
ios cocoapods cocoapods的安装 cocoapods的更新

今天研究了一下突然发现cocoapods的版本过低了,然后自己进行更新了一下,在这里分享一下自己安装及更新cocoapods的过程. 1.安装 对于cocoa pods,大家都知道是一个依赖ruby语言开发的,在安装pod之前,需要检查一下自己的ruby环境,一般mac上是自带ruby环境的,如果没有可以自己安装一下. 检查自己的ruby环境: $ gem -v gem介绍:gem是一个管理Ruby库和程序的标准包,它通过Ruby Gem(如 http://rubygems.org/ )源来查找、安装、升级和卸载软件包,非常的便捷。 (1)更换gem源 因为国内网络的问题导致gem源间歇性中断,原因你懂的。因此我们需要更换gem源,使用淘宝的gem源 https://ruby.taobao.org/. 第一步:移除默认的源 gem sources --remove https://rubygems.org/ 第二步:指定淘宝的源 gem sources -a https://ruby.taobao.org/

第三步:查看指定的源是不是淘宝源 $ gem sources -l 结果是 CURRENT SOURCES https://ruby.taobao.org/

如果是https://ruby.taobao.org/,则更换成功。

(2)安装CocoaPods 改成淘宝源后执行以下命令进行安装: sudo gem install cocoapods 如果换成国内镜像使用 gem install cocoapods 报错: ERROR: While executing gem ... (Gem::DependencyError) Unable to resolve dependencies: cocoapods requires cocoapods-core (= 1.1.1), cocoapods-downloader (< 2>= 1.1.2), cocoapods-trunk (< 2>= 1.1.1), xcodeproj (< 2>= 1.3.3) 执行: sudo gem update --system && sudo gem install cocoapods 报错: ERROR: While executing gem ... (Errno::EPERM) Operation not permitted - /usr/bin/xcodeproj 执行: sudo gem install -n /usr/local/bin cocoapods 安装完成,输入以下命令检测是否安装成功: $ pod --version 一般情况下,这样就能够完成安装

2.更新: 一般安装过cocoa pods的在次安装就比较简单了. 首先检查一下自己的ruby和gem的版本.有时候可能需要进行更新一下. (1)更新ruby 官网下载最新版本ruby:http://www.ruby-lang.org/en/downloads/ 在解压缩文件夹里进行编译 ./configure sudo make sudo make install ruby -v查看ruby 版本 ,例如如下信息 ruby 2.3.3p222 (2016-11-21 revision 56859) [x86_64-darwin16] (2)升级更新Gem 依次执行以下内容:

执行sudo gem update --system 执行sudo gem install rubygems-update 执行 sudo update_rubygems

(3)检查你的ruby源

$gem source - l 然后,按照上述(2)安装cocoapods的过程来进行安装,就可以了.

3.删除CocoaPods版本,并安装指定版本

比如我本来安装完CocoaPods 1.0.0版,但发现它实现跟先前还是差别满大的,决定降回0.39这个比较稳定版本;就可以用命令先删除本地的CocoaPods版本,再指定安装特定版本;

a. 卸载 cocoapods(它会提示你要删除本地哪个版也可以全删) sudo gem uninstall cocoapods

b. 安装 0.39版本 sudo gem install -n /usr/local/bin cocoapods -v 0.39

4.对于一些使用过程中常见的问题

cd到自己的项目目录下 创建Podfile vim Podfile 如果没有创建Podfile 文件将无法安装, CocoaPods都不知道改安装说明, 怎么去安装呢, 对吧. [!] No `Podfile' found in the project directory.

输入以下代码(配置文件,需要添加的第三方):

source 'https://github.com/CocoaPods/Specs.git'

platform :ios, '8.0'   inhibit_all_warnings!

  target '工程名' do

  pod 'AFNetworking', '~> 2.6.0'

  end

然后保存退出 esc :wq 执行 pod updateOR pod install。 如果报错:

[!] Unable to add a source with url https://github.com/CocoaPods/Specs.git named master. You can try adding it manually in ~/.cocoapods/repos or via pod repo add. 执行: sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer(xcode目录)

红色部分是我的Xcode的路径,注意上面的代码中的"--"和"select"之间有一个空格。

解决方法可以使用一下代码:

又产生的问题:一般这个时候会输出--unalbe to get active developer directory

defaults write com.apple.finder _FXShowPosixPathInTitle -bool TRUE;killall Finder

这样的话就可以了,然后用你的Xcode的路径代替上面的红色的部分就可以了。

问题描述

1:[!] The 'master' repo requires CocoaPods 1.0.0 - (currently using 0.39.0) Update CocoaPods, or checkout the appropriate tag in the repo.

问题原因:没有更新到最新cocoapods版本

  sudo gem install -n /usr/local/bin cocoapods –pre

  如果报错或其他问题

  sudo gem update --system && sudo gem install cocoapods

  出现报错信息:   ERROR: While executing gem ... (Errno::EPERM) Operation not permitted - /usr/bin/xcodeproj

  执行:   sudo gem install -n /usr/local/bin cocoapods

  输入以下命令检测是否成功:   pod --version 1.1.1

2:[!] The dependency AFNetworking (~> 2.6.0) is not used in any concrete target.等

问题原因:podfile升级到最新版本,pod里的内容必须明确指出所用第三方库的target

可以修改Podfile文件的配置文件,让它兼容不指定固定版本;且又不报错

  platform :ios, '8.0'

  inhibit_all_warnings!

  target '工程名' do

  pod 'AFNetworking', '~> 2.6.0'

  end

3:Updating local specs repositories

遇到pod install或者pod update长时间卡在Updating local specs repositories

常见的解决方式是跳过更新cocoapods的spec仓库 pod install --verbose --no-repo-update pod update --verbose --no-repo-update 最好的办法是 pod repo remove master pod setup pod install 4:[!]Your Podfile has had smart quotes sanitised. To avoid issues in the future, you should not use TextEdit for editing it. If you are not using TextEdit, you should turn off smart quotes in your editor of choice.

  不要使用文本编辑去编辑Podfile,使用Xcode编辑,或者使用终端敲命令去编辑。或者输入格式错误,没输入运行版本:$platform:ios, ‘8.0‘

5:使用cocoapods导入第三方类库后头文件没有代码提示?

  选择Target -> Build Settings 菜单,找到\”User Header Search Paths\”设置项,新增一个值"${SRCROOT}",并且选择\”Recursive\”

6:[!]Unable to find a target named ' ';

  Podfile的工程文件和建立工程名不一致。名字改为一致即可

7:syntax error ,unexpected end-of-input,expecting keyword_end

  podfile写法有问题,使用标准的podfile的写法

  platform :ios, '8.0'

  inhibit_all_warnings!

  target '工程名' do

  pod 'AFNetworking', '~> 2.6.0'

  end

8: Analyzing dependencies

 [!]Could not automatically select an Xcode project . Specify one in your Podfile like 50 : xcodeproj ' path / to / Project . xcodeproj

  自己建立了一个空文件夹,没有建立工程

  处理方法:删除这个空工程,重新建立一个工程,再按照上面知识点讲解一步步来即可。

9:pod 导入后出现"_OBJCCLASS$_xxx"

  target->build phases->link binary with libraries添加xxx.a

  如果不是pod导入的类库,出现这种问题

  原因:在创建类的时候没有勾选"add to targets"

  target->build phases->compile sources 添加.h,.m文件

  或(建议用上面)   在Build Setting 中的Other Linker Flags选项中加入$(OTHER_LDFLAGS)

10:Xcode - ld: library not found for -lPods

当新增加一个Target,并且pod install后,由于创建项目是默认创建的Target的Build Phases中引用了旧的.a,例如libPods.a,当新增加Targget后,libPods.a已经变成了libPods-Test.a,而新增加的Target名字为Second,依赖的.a为libPods-Second.a。所以libPods.a此时已经不再被引用,并且不会被生成,如果任何地方引用了就会报错,解决办法是出现问题的Target的Build Phases中删除无用的.a引用,例如libPods.a   target->build phases->link binary with libraries 11:pod 导入库,找不到头文件

  在TARGETS -> Search Paths -> User Header Search Paths 中 写入 ${SRCROOT}再将后面参数改为recursive:

12:如果要移除Cocoapods,则可以:

  a. 删除工程文件夹下的Podfile、Podfile.lock及Pods文件夹   b. 删除xcworkspace文件   c. 使用xcodeproj文件打开工程,删除Frameworks组下的Pods.xcconfig及libPods.a引用   d. 在工程设置中的Build Phases下删除Check Pods Manifest.lock及Copy Pods Resources   不小心删除pods.xcconfig,出现diff: /../Podfile.lock: No such file or directory

  sudo pod install一下就好了

  如果编译的时候出现权限问题,对工程文件夹$sudo chmod 777 path-to-project-folder/   $sudo chown 777 path-to-project-folder/ 13:出现/Library/Ruby/Gems/2.0.0/gems/claide-0.8.1/lib/claide/command.rb:417:in `help!': [!] You cannot run CocoaPods as root. (CLAide::Help)

  重新打开一个终端,然后pod install,不要sudo pod install。 14:删除CocoaPods版本,并安装指定版本

  比如我本来安装完CocoaPods 1.0.0版,但发现它实现跟先前还是差别满大的,决定降回0.39这个比较稳定版本;就可以用命令先删除本地的CocoaPods版本,再指定安装特定版本;

  a 卸载 cocoapods(它会提示你要删除本地哪个版也可以全删)

  sudo gem uninstall cocoapods

  b 安装 0.39版本

  sudo gem install -n /usr/local/bin cocoapods -v 0.39

15:更新 CocoaPods 或者以前手动添加过第三方SDK改用Cocopods,可能会出现以下的错误

错误1:

 [!] The `Paopao [Debug]` target overrides the `PODS_ROOT` build setting defined in `Pods/Target Support Files/Pods/Pods.debug.xcconfig'. This can lead to problems with the CocoaPods installation
  • Use the $(inherited) flag, or
  • Remove the build settings from the target.

    [!] The Paopao [Debug] target overrides the OTHER_LDFLAGS build setting defined in `Pods/Target Support Files/Pods/Pods.debug.xcconfig'. This can lead to problems with the CocoaPods installation

  • Use the $(inherited) flag, or
  • Remove the build settings from the target.

    [!] The Paopao [Release] target overrides the PODS_ROOT build setting defined in `Pods/Target Support Files/Pods/Pods.release.xcconfig'. This can lead to problems with the CocoaPods installation

  • Use the $(inherited) flag, or
  • Remove the build settings from the target.

    [!] The Paopao [Release] target overrides the OTHER_LDFLAGS build setting defined in `Pods/Target Support Files/Pods/Pods.release.xcconfig'. This can lead to problems with the CocoaPods installation

  • Use the $(inherited) flag, or
  • Remove the build settings from the target.   产生此警告的原因是项目 Target 中的一些设置,CocoaPods 也做了默认的设置,如果两个设置结果不一致,就会造成问题。

  我想要使用 CocoaPods 中的设置,分别在我的项目中定义PODS_ROOT 和 Other Linker Flags的地方,把他们的值用$(inherited)替换掉,进入终端,执行

  pod update

  警告没了

  一种简单粗暴的方法:

  点击项目文件 project.xcodeproj,右键显示包内容,用文本编辑器打开project.pbxproj,删除OTHER_LDFLAGS的地方,保存,pod update,警告没了。。。。

感谢雨季的雾这位小伙伴的分享.详细资料请看http://www.cnblogs.com/yujidewu/p/6125218.html

收藏
1
sina weixin mail 回到顶部