博客> cocoapods update 错误
cocoapods update 错误
2017-10-17 17:07 评论:0 阅读:206 向上的小草
ios cocoapods update错误 nanaimo文件冲突

今天在工程中添加一个新的第三方库,然后cd到目录下进行update,结果...

在命令行中出现了一堆错误!

Report

  • What did you do?

  • What did you expect to happen?

  • What happened instead?

Stack

经过仔细查看,并躺了很多坑之后,最终定位到其中的一行log:LoadError - cannot load such file -- nanaimo 于是查看了nanaimo文件的状态。 1.在终端输入命令: gem list | grep nanaimo

发现有两个nanaimo文件(分别是0.2.2和0.2.3两个版本),判定有可能是nanaimo文件冲突,如此之后抱着死马当活马医的态度去卸载文件

2.在终端输入命令:sudo uninstall nanaimo
然后选择要卸载的版本,卸载成功后再执行update命令:pod update

焦急等待几分钟之后,终于发现了一串绿色!成功!

 以上仅为坑里的兄弟做个提示。如果对你有用请赞一个!在此先行谢过!
收藏
0
sina weixin mail 回到顶部