博客> RuntimeError - [Xcodeproj] Unknown object version.
RuntimeError - [Xcodeproj] Unknown object version.
2018-09-23 19:46 评论:0 阅读:203 dayspring
CocoaPod RuntimeError

今天使用cocoapod突然报错,查了下可能是前几天更新Xcode造成与cocoapod版本不匹配的原因,在此记录一下,希望与我有相同困惑的人可以有所帮助。

Error


RuntimeError - [Xcodeproj] Unknown object version.
.rvm/gems/ruby-2.3.0@global/gems/xcodeproj-1.4.4/lib/xcodeproj/project.rb:217:in `initialize_from_file'
.rvm/gems/ruby-2.3.0@global/gems/xcodeproj-1.4.4/lib/xcodeproj/project.rb:102:in `open'
.rvm/gems/ruby-2.3.0@global/gems/cocoapods-1.2.1/lib/cocoapods/installer/analyzer.rb:874:in `block (2 levels) in inspect_targets_to_integrate'
.................
――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

[!] Oh no, an error occurred.

Search for existing GitHub issues similar to yours:
https://github.com/CocoaPods/CocoaPods/search?q=[Xcodeproj]+Unknown+object+version.&type=Issues

If none exists, create a ticket, with the template displayed above, on:
https://github.com/CocoaPods/CocoaPods/issues/new

Be sure to first read the contributing guide for details on how to properly submit a ticket:
https://github.com/CocoaPods/CocoaPods/blob/master/CONTRIBUTING.md

Don't forget to anonymize any private data!

解决方法:
gem install cocoapods --pre

注:
为了对比,运行上面命令以前可以先查看一下cocoapod的版本号
pod --version
1.2.1
运行以后查看当前cocoapod的版本号
pod --version
1.5.3
收藏
0
sina weixin mail 回到顶部